NodeJS nodejs 降级,安装低版本

阅读(6575)

某些框架并不能跟上nodejs的步伐,需要使用低版本的nodejs才能正常运行。推荐一个Node版本管理工具:NVM(Node Version Manager - Simple bash script to manage multiple active node.js versions)。

安装

curl -o- https://raw.githubusercontent.com/creationix/nvm/v0.31.1/install.sh | bash

此脚本会将nvm加入到当前的source,如~/.bash_profile, ~/.zshrc, ~/.profile, or ~/.bashrc,这样就能支持输入nvm了。

检测是否安装成功

command -v nvm

若安装成功,会输出nvm;否则,请尝试重启shell。

常用命令

列出所有版本:nvm ls-remote

安装指定版本:nvm install <version>,如nvm install v5.1

使用指定版本(修改PATH):nvm use <version>

查看当前使用版本:nvm ls

支持的系统

需要注意的是,NVM支持OS X、Linux,但不支持windows,并在Project一再声明多个类似NVM并非出自他们之手。

via: https://github.com/creationix/nvm

Tags: nvm